Notification: Issue identified with Insurity Decisions Suite

Incident Report for Insurity

Resolved

This incident has been resolved.
Posted Feb 24, 2026 - 09:11 EST

Update

The following is an important message from Insurity Customer Support.

As of 9:00 AM EST, Insurity Cloud Operations can confirm that all applications and related functions of our platform are fully operational.

Please note that at this time, there are no further update planned on this incident. We are sorry for the inconvenience this may cause you and thank you for your cooperation.

Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Feb 24, 2026 - 09:10 EST

Investigating

The following is an important message from Insurity Customer Support.

An issue has been raised to the Insurity Cloud Operations team of a problem affecting our Insurity Decisions Suite platform. We are currently investigating the issue and an email will be sent once it has been resolved.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.

Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Feb 24, 2026 - 08:33 EST
This incident affected: Insurity Decisions Suite (Insurity Public Cloud - US).