The following is an important message from Insurity Customer Support.
As of 5:30 PM EST, Insurity Cloud Operations can confirm that all applications and related functions of our platform are fully operational.
Please note that at this time, there are no further update planned on this incident. We will however communicate per our standard incident management practices if required.
Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Mar 03, 2025 - 17:31 EST
Monitoring
The following is an important message from Insurity Customer Support.
We are continuing to work with our partners to resolve the issue impacting our systems.
As of 13:40 EST, we are starting to notice service restoration across all products and are coordinating with MS Azure on resolution and root cause. We are continuing to monitor the Insurity Cloud to ensure that all applications and related functions of our platform are fully operational and will take remediation steps where required.
The best method to track the status of our platform will continue to be through this status page.
We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Mar 03, 2025 - 13:58 EST
Investigating
The following is an important message from Insurity Customer Support.
An issue has been raised to the Insurity Cloud Operations team of a problem affecting some of our products. We are currently investigating the issue and an email will be sent once it has been resolved.
We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Mar 03, 2025 - 12:21 EST
This incident affected: Insurity Bridge Specialty Suite (Insurity Public Cloud - Canada), Insurity Marine Suite (Insurity Public Cloud - Canada), Insurity Workers’ Comp Suite (Insurity Public Cloud - Canada), and Insurity ClaimsXPress (Insurity Public Cloud - Canada).