Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 20, 2026 - 18:00 EST
Scheduled
Dear Customers,
We will be upgrading our Anywhere 365 telephony platform on Friday, February 20, between 6:00 PM and 8:00 PM EST.
During this window, all incoming support calls will be routed to our external call center and then transferred into the Insurity Support Portal as applicable. There is no expected downtime for the Insurity application itself, though you may experience slightly longer response times on phone calls.
Chat, email-based support, and the Support Portal will not be impacted and will operate as normal.
This upgrade moves us to the latest supported Anywhere 365 version, improving stability, security, and routing capabilities so we can continue to enhance overall support performance.
Posted Feb 19, 2026 - 16:58 EST
This scheduled maintenance affected: Insurity Bridge Specialty Suite (Insurity Public Cloud - Canada, Insurity Public Cloud - US), Insurity Marine Suite (Insurity Public Cloud - Canada), Insurity Workers’ Comp Suite (Insurity Public Cloud - Canada, Insurity Public Cloud - US), Insurity Billing-as-a-Service (Insurity Public Cloud - US), Insurity ClaimsXPress (Insurity Public Cloud - US - New, Insurity Public Cloud - US - Old, Insurity Public Cloud - Canada), Insurity Decisions Suite (Insurity Public Cloud - Canada, Insurity Public Cloud - US), and Insurity Support Applications (Anywhere 365).