Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 13, 2026 - 23:30 EST
Scheduled
The following is an important message to all Insurity Marine Suite Customers.
Please be advised that Insurity will be performing a PingFederate SSO license update tonight in our Production Environment for the date and time specified. This is an infrastructure-only change and no application downtime is expected.
- Scope: PingFederate SSO platform - Impact on applications: No direct impact expected to IMS - Availability: SSO and applications are expected to remain available throughout the update
In the unlikely event that any user experiences issues signing in to IMS via SSO during or after this update (for example, authentication failures or unexpected login errors), please contact Insurity Customer Support, support@insurity.com, promptly so we can assist you.
Thank you for your understanding and continued partnership.
Posted Feb 13, 2026 - 12:37 EST
This scheduled maintenance affected: Insurity Marine Suite (Insurity Public Cloud - Canada).