Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 14, 2024 - 08:00 EST
Scheduled
The following is an important message to Insurity Sure Claims Payments Customers from Insurity Customer Support.
Notification: Insurity Sure Claims Payments Disaster Recovery exercise is planned for Saturday, December 14, 2024 from 8:00am-1:00pm ET.
During this Disaster Recovery exercise, the Insurity Sure Claims Payments application will not be available while we are running tests in the secondary region.
Please contact your Customer Success Representative or Customer Support if you have any questions.
Thank you,
Posted Dec 10, 2024 - 12:16 EST
This scheduled maintenance affected: Sure Payments (Insurity Public Cloud - US).