Notification: Issue identified with various products
Incident Report for Insurity
Resolved
This incident has been resolved.
Posted Jul 23, 2024 - 10:22 EDT
Update
We are continuing to monitor for any further issues.
Posted Jul 20, 2024 - 18:13 EDT
Monitoring
The following is an important message from Insurity Customer Support.

As of 2:00 PM EST, Insurity Cloud Operations has returned the remaining portions of the Insurity Cloud online. We are continuing to monitor the Insurity Cloud to ensure that all applications and related functions of our platform are fully operational and will take remediation steps where required. Our teams continue to be fully mobilized to allow for rapid response to any new issues and to ensure that the Insurity Cloud is working optimally ahead of Monday.

Please note that at this time, there are no further update planned on this incident. We will however communicate per our standard incident management practices if required.

Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Jul 20, 2024 - 13:57 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems.

As of 8:00 AM EST, Insurity Operations is continuing to bring the last remaining portions of the Insurity Cloud online. More systems have come online over the past few hours and are expected to continue to progress throughout the day. Insurity's Operations teams are working to restore our entire cloud to a fully operational state as rapidly as possible.

The best method to track the status of our platforms will continue to be through this status page.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 20, 2024 - 07:54 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems.

As of 10:00 PM EST, Insurity Operations is continuing to bring the last remaining portions of the Insurity Cloud online. More systems have come online in the last 2 hours and are expected to continue to progress before the end of the day. Insurity's Operations teams are working to restore our entire cloud to a fully operational state as rapidly as possible.

The best method to track the status of our platforms will continue to be through this status page. Please note that the next update will be provided tomorrow morning.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 19, 2024 - 21:56 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems.

As of 8:00 PM EST, Insurity Operations is continuing to bring the remaining portions of the Insurity Cloud online. Many systems have come online in the last few hours and others are expected to be online later this evening. Insurity's Operations teams are working to restore our entire cloud to a fully operational state as rapidly as possible.

The best method to track the status of our platforms will continue to be through this status page.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 19, 2024 - 20:14 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems.

As of 4:00 PM EST, Insurity Operations continues to bring online additional portions of the Insurity Cloud and are actively working on resolving the situation for the rest of our systems. Additional systems are expected to be online within the next 2 hours. There remains no ETA as to when all of our platforms will be fully operational.

The best method to track the status of our platforms will continue to be through this status page.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 19, 2024 - 16:02 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems.

As of 2:00 PM EST, Insurity Operations continues to bring online additional portions of the Insurity Cloud and are actively working on resolving the situation for the rest of our systems. There remains no ETA as to when all of our platforms will be fully operational.

The best method to track the status of our platforms will continue to be through this status page.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 19, 2024 - 14:12 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems.

As of 11:45 EST, Insurity Operations have begun to bring online a portion of the Insurity Cloud and are actively working on resolving the situation for the rest of our systems. There remains no ETA as to when all of our platforms will be fully operational.

The best method to track the status of our platform will continue to be through this status page.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 19, 2024 - 12:49 EDT
Update
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems. There is currently no ETA as to when our platform will be fully operational and are actively working on resolving the situation.

The best method to track the status of our platform will continue to be through this status page.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.
Posted Jul 19, 2024 - 10:57 EDT
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 08:44 EDT
Identified
The following is an important message from Insurity Customer Support.

We are continuing to work with our partners to resolve the Crowdstrike / Microsoft issue impacting our systems. We will continue to provide updates as the situation evolves.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.

Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Jul 19, 2024 - 06:54 EDT
Update
We are continuing to investigate this issue.
Posted Jul 19, 2024 - 06:52 EDT
Investigating
The following is an important message from Insurity Customer Support.

An issue has been raised to the Insurity Cloud Operations team of a problem affecting some of our products. We are currently investigating the issue and an email will be sent once it has been resolved.

We are sorry for the inconvenience this may cause you and thank you for your cooperation.

Please do not hesitate to contact Customer Support through our support portal if you have any questions.
Posted Jul 19, 2024 - 02:40 EDT
This incident affected: Insurity Bridge Specialty Suite (Insurity Public Cloud - Canada, Insurity Private Cloud - US, Insurity Private Cloud - Canada (Non Production)), Sure Payments (Insurity Public Cloud - US), Insurity Decisions Suite (Insurity Private Cloud - US, Insurity Public Cloud - Canada), Insurity Marine Suite (Insurity Public Cloud - Canada), Insurity Workers’ Comp Suite (Insurity Public Cloud - Canada, Insurity Private Cloud - US), Sure MGA Suite (Insurity Public Cloud - US), Sure Billing-as-a-Service (Insurity Public Cloud - US), Sure Premium Audit / Sure Loss Control (Insurity Public Cloud - US), Insurity Business Intelligence (Insurity Public Cloud - US, Insurity Public Cloud - Canada), and Insurity ClaimsXPress (Insurity Public Cloud - US - New, Insurity Public Cloud - US - Old, Insurity Private Cloud - US, Insurity Public Cloud - Canada).