Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 14, 2024 - 13:00 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 10, 2024 - 12:18 EST
Update
We will be undergoing scheduled maintenance during this time.
Posted Dec 10, 2024 - 12:11 EST
Scheduled
The following is an important message to all Sure Submission Gateway Customers from Insurity Customer Support.
Our annual Sure Submission Gateway Disaster Recovery exercise is planned for Saturday, December 14, 2024 from 1:00pm-8:00pm ET.
During this Disaster Recovery exercise, the Sure Submission Gateway application will not be available while we are running tests in the secondary region.
Please do not hesitate to contact your Customer Success Representative or Customer Support if you have any questions.
Posted Dec 10, 2024 - 12:10 EST
This scheduled maintenance affected: Sure Submission Gateway (Insurity Public Cloud - US).